SQDR Plus System Requirements

SQDR Plus currently supports incremental replication from IBM DB2 for i (iSeries) hosts, including IBM i 7.3, IBM DB2 for Linux, UNIX, and Windows (DB2 for LUW aka Db2), Microsoft SQL Server, Oracle, IBM Informix, and MySQL. The system requirements for using SQDR Plus with these hosts are provided below.

SQDR Plus Requirements

You can install and run the StarQuest Data Replicator Plus on computers running the following software:

  • Microsoft Windows Server 2008R2sp1, 2012, 2012R2, 2016, 2019
  • Microsoft Windows 7sp1, 8, 8.1, 10 (64-bit)
  • Linux x86-64 (AMD64 & Intel EM64T)

You can replicate data from the following source database systems:

  • IBM DB2 for i v5r4 or later
  • IBM DB2 for Linux, UNIX and Windows v9.7 or later (all platforms)
  • Microsoft SQL Server using Change Tracking - SQL Server 2008 or later (any edition)
  • Microsoft SQL Server using Change Data Capture - SQL Server 2008R2 or later (Enterprise and Developer Editions) or SQL Server 2016sp1 or later (Standard, Enterprise, Developer Editions)
  • Oracle 11g or 12c
  • IBM Informix 11.70 or later
  • MySQL (Community or Enterprise Edition) 5.6 or later
  • MariaDB 10.x or later
  • Amazon Web Services Aurora
  • Amazon Relational Database Service (RDS) for MySQL 5.6 or later
  • Google Cloud SQL for MySQL

IBM DB2 Express (bundled with SQDR Plus) is installed on the computer running SQDR Plus for use as a control database and temporary store.