StarPipes System Requirements

StarPipes provides a robust multiprotocol gateway for access to IBM DB2 databases from Microsoft Windows, UNIX, or Java client and server-based applications. StarPipes' SSL (Secure Sockets Layer) support provides secure connections over public networks without updates or configuration changes to either the client or the database host.

StarPipes also provides TCP/IP access to legacy DB2 systems that are accessed using SNA.

StarPipes is designed to be installed and run from a Windows-based computer.

StarPipes can connect to the following databases:

  • DB2 for z/OS and OS/390 ( DB2/MVS) Version 2.3 and later
  • DB2 for i (DB2/400, DB2 UDB for iSeries, and DB2 for i5/OS) Version 2.2 and later
  • SQL/DS (DB2 for VM & VSE) Version 3.3 and later
  • DB2/UDB for Linux, UNIX,and Windows Version 6.1 and later
  • Apache Derby (JavaDB) 10.3 or later

The following host databases provide native DRDA over TCP/IP support:

  • DB2 for z/OS and OS/390 v5.1 and later
  • DB2 for i (DB2/400, DB2 UDB for iSeries, and DB2 for i5/OS) v4r2 and later
  • DB2 Universal Database for Linux, UNIX and Windows v6.1 and later
  • Apache Derby (JavaDB) 10.3 or later
  • DB2 for VM 7.1 and later

The following host databases provide SSL support:

  • DB2 for z/OS v9.1 and later
  • DB2 for i (DB2/400, DB2 UDB for iSeries, and DB2 for i5/OS) v5r1 and later
  • DB2 Universal Database for Linux, UNIX and Windows v9.1 and later
  • Apache Derby (JavaDB) 10.3 or later

Systems Requirements

  • Windows Server 2019, 2016, 2012R2, 2012, 2008R2 and Windows 10, 8.1, 8, and 7. If you are using a 64-bit version of one of these operating systems, you can install either the 32-bit or the 64-bit version of StarPipes.
  • TCP/IP support
  • For SNA support on a 32-bit Windows operating system, use the 32-bit version of StarPipes with either:
    • Microsoft Host Integration Server 2000 or later
    • IBM Communications Server for NT v5.01 or later
  • For SNA support on a 64-bit Windows operating system, use either the 64-bit version of StarPipes with the 64-bit version of Microsoft Host Integration Server 2006 or later or the 32-bit version of StarPipes with the IBM Communications Server for NT v5.01 or later.